Mittlerweile ist mein Tuxedo XC1506 eigentlich alles soweit in komplett eingerichtet und in bester Ordung.

Immer ist Wifi im Flugmodus nach dem Resume, also wenn der Laptopdeckel wieder aufgeklappt wird.

Das ist ja nicht weiter schlimm, ein Druck auf Fn F11 schaltet wlan wieder an, es geht auch fix und man ist wieder mit dem heimischen Wlan verbunden.

Momentan allerdings hatte ich bereits 3 mal, dass das Flugsymbol zwar wegging, aber kein wifi Symbol auftauchte, auch nicht die 3 Punkte, die während der Initialisierung zu sehen sind.

Wie aktuell der Mechanismus im System umgesetzt wird, habe ich nicht evaluiert, sicher würde ein Eintrag reichen, um das iwlwifi und / oder das modul iwlmvm zu entladen und beim resume neu zu laden.

Als Workaround, bis ich den korrekten Weg gefunden habe, mache ich das mit folgenden Miniscript:

Genannt habe ich es /usr/local/bin/wifi-repair.sh

CODE:
sudo rmmod iwlmvm sudo rmmod iwlwifi sleep 1 sudo modprobe iwlwifi iwlmvm 

Damit bin ich in der Lage, im Falle eines Falles mal eben schnell Wifi zu reaktivieren.

No comments

Add Comment

E-Mail addresses will not be displayed and will only be used for E-Mail notifications.

To prevent automated Bots from commentspamming, please enter the string you see in the image below in the appropriate input box. Your comment will only be submitted if the strings match. Please ensure that your browser supports and accepts cookies, or your comment cannot be verified correctly.
CAPTCHA

Standard emoticons like :-) and ;-) are converted to images.
BBCode format allowed
Markdown format allowed